И mplayer беше се предал

…пред моите опити за ъпгрейд на библиотеки.
Имаше
mplayer: error while loading shared libraries: libglib-1.2.so.0: cannot open shared object file: No such file or directory
И докато не върнах стария glib-1 не тръгна.
Пробвах да компилирам MPlayer 1.0rc2 (последната версия, която беше достъпна за сваляне) и там имаше неуспех…

/usr/lib/gcc/i486-slackware-linux/3.4.6/../../../../i486-slackware-linux/bin/ld: warning: libslang.so.1, needed by /usr/lib/libaa.so, may conflict with libslang.so.2
/usr/local/lib/libcairo.so: undefined reference to `FT_GlyphSlot_Embolden'
collect2: ld returned 1 exit status
make: *** [mplayer] Error 1

Това пък вероятно е от ъпгрейда на cairo-то…

Извод: не почвайте да ъпгрейдвате библиотеки в Slackware, освен ако нямате цял свободен ден и много нерви за следене на dependencies
Почвам да се замислям за разни менажери на зависимости като swaret, swapt-get и slackpkg 🙁

Tags: , ,

Leave a Reply